M4 firing irregularly

Having problems? Ask a question.

M4 firing irregularly

Postby Lobo » Fri Oct 28, 2011 4:06 pm

I own an M4 based on a G&G Sportline M4 (Plastica, not CM). I variety of aftermarket parts have been installed, which I will post if that becomes a relevant concern. It remains wired to the front.

After having been kept in the case for several months, I pulled the gun out to test it. I fires just fine, except that after a bit of shooting (roughly 80-200 rounds) it will completely stop, sometimes in the middle of a gearbox cycle. I can pull the trigger and feel the trigger assembly move, but nothing happens. Oddly enough, after waiting a minute or two, it will resume working as if nothing happened.

What do you think?
Also known as Lawrence of Arabia
User avatar
Lobo
First Lieutenant
First Lieutenant
 
Posts: 537
Joined: Sun Jul 19, 2009 2:47 pm
Location: Anchorage

Re: M4 firing irregularly

Postby Cheese Man » Fri Oct 28, 2011 5:55 pm

This happened with Mach's SR-25, it turned out that his fuse was being weird, and once we replaced that it worked fine.
I offer a range of airsmithing services, give them a try!
https://sites.google.com/site/cheesemanindustries/home

Up the Classics!
Cheese Man
First Lieutenant
First Lieutenant
 
Posts: 560
Joined: Tue Jun 01, 2010 9:54 am
Location: Anchorage, AK

Re: M4 firing irregularly

Postby Lobo » Fri Oct 28, 2011 7:50 pm

The problem is that I bypassed my fuse a while ago.
Also known as Lawrence of Arabia
User avatar
Lobo
First Lieutenant
First Lieutenant
 
Posts: 537
Joined: Sun Jul 19, 2009 2:47 pm
Location: Anchorage

Re: M4 firing irregularly

Postby Cheese Man » Fri Oct 28, 2011 8:04 pm

Hmm. Have you checked the wiring for kinks/shorts? Or, you might check your battery, that could be funky.
I offer a range of airsmithing services, give them a try!
https://sites.google.com/site/cheesemanindustries/home

Up the Classics!
Cheese Man
First Lieutenant
First Lieutenant
 
Posts: 560
Joined: Tue Jun 01, 2010 9:54 am
Location: Anchorage, AK

Re: M4 firing irregularly

Postby Kyle » Fri Oct 28, 2011 8:06 pm

My money's on the motor if the problem is onset by firing the gun a bit, then goes away as it "cools off".

Try a different motor if possible, or pull the grip off, run the motor out of the gearbox for a bit without a load, and see if it dramatically slows down or stops after getting hot.
AirsoftFix, LLC | 700 W 41ST Ave. Suite D, Anchorage, AK 99503
1-855-AIRSOFT | http://www.airsoftfix.com | contact@airsoftfix.com
User avatar
Kyle
Sergeant Major
Sergeant Major
 
Posts: 437
Joined: Wed Jun 10, 2009 9:41 am
Location: Anchorage, AK

Re: M4 firing irregularly

Postby Lobo » Sat Oct 29, 2011 10:22 pm

Well, I ran the motor out of the gearbox for a while, and nothing unusual seemed to happen. I put a different motor in to test, and it seems to be working fine.

Thanks for the help. We will see how it goes on the 6th.
Also known as Lawrence of Arabia
User avatar
Lobo
First Lieutenant
First Lieutenant
 
Posts: 537
Joined: Sun Jul 19, 2009 2:47 pm
Location: Anchorage


Return to Technical Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron