Problem with ICS SR-16

Having problems? Ask a question.

Problem with ICS SR-16

Postby TheUgly » Sat Aug 06, 2011 6:43 pm

So I have this here rifle.

http://www.airsoftpost.com/product_info ... s_id=28309

The gearbox was making some sort of weird grinding noise and BBs were only firing a few feet and now are only dropping out of the barrel and I inspected the upper half of the gearbox, its a two piece, and found the spring guide to be broken. It was a plastic one and I had an old gearbox from an Airsoft Elite MP5A4 so i took the brass spring guide out of it and replaced the broken one. It fit perfectly and was the same dimensions.

I put it back together and fired it, everything seemed fine, I could feel the push of air coming out the barrel, and it seemed to be cycling perfectly. However, the bbs were still just falling out the front and the gearbox was making a weird noise. I took the lower half out that contains the gears, the selector switch, tappet plate, wires, and everything were fine. None of the gears seem to have any missing teeth.

I took out the hopup and checked the bucking, it seems to be perfectly fine too and if I drop a bb into the hopup and blow through it the bb flys out as it normally would.

The motor is fine and not missing any teeth and works fine, I havent found a single other broken thing. If I look into the feed tube in the magwell with a flashlight and pull the trigger I can see the nozzle cycling back and forth but it definitely is not consistent and never stops in the same place and I cant tell but it doesn't seem like it is moving forward all the way.

Is the seal not being made and thats why BBs are just falling out and not firing?

Is the gearbox messed up?

Is there a problem with the bucking?

Is it because of the new spring guide because with the broken one the bbs at least fired ten feet?

Thoughts? All comments and speculation are appreciated.
User avatar
TheUgly
Master Sergeant
Master Sergeant
 
Posts: 303
Joined: Sun Apr 26, 2009 9:43 pm

Re: Problem with ICS SR-16

Postby GoodasDead » Sat Aug 06, 2011 11:30 pm

Make sure you put the cylinder in the right way, if it's ported and in the wrong way you will get horrible compression.
If you have any Sniper Rifle questions, PM me.
User avatar
GoodasDead
Sergeant Major
Sergeant Major
 
Posts: 411
Joined: Wed Apr 22, 2009 7:09 pm

Re: Problem with ICS SR-16

Postby TheUgly » Sun Aug 07, 2011 12:50 am

Roger that! I put the damn ported cylinder in backwards so the windows were up front and there was no compression.

However I just switched it around and the BBs are once again flying only 10 or so feet.
User avatar
TheUgly
Master Sergeant
Master Sergeant
 
Posts: 303
Joined: Sun Apr 26, 2009 9:43 pm

Re: Problem with ICS SR-16

Postby AlienAlaska » Mon Aug 08, 2011 12:53 am

need to do a though cleaning of the piston o-ring and the air nozzle and all other parts of the upper gear box then re lube with a silicon gel and see if that helps
I fix/upgrade guns PM me
AlienAlaska
Master Sergeant
Master Sergeant
 
Posts: 316
Joined: Mon Apr 20, 2009 11:59 pm

Re: Problem with ICS SR-16

Postby TheUgly » Mon Sep 12, 2011 4:08 pm

Well ive torn that damn thing apart at least 60 times now. Relubed the upper, put more grease in the lower, checked everything put a new piston in, the same exact type of piston, didnt work, put the old one back, checked the hop up, doesnt seem to be any problemsss it still wont fire a BB more than two feet and it can only fire every 3-4 shots.

Question though. Is the piston O-Ring supposed to be loose or should it be tight around the front of the piston. Mine is loose on both the one in the rifle and the replacement one.
User avatar
TheUgly
Master Sergeant
Master Sergeant
 
Posts: 303
Joined: Sun Apr 26, 2009 9:43 pm

Re: Problem with ICS SR-16

Postby TheMightyMoe » Mon Sep 12, 2011 6:42 pm

Did you do a compression test before putting it together?
Castner's Cutthroats,
Alaska's finest.
And when you gaze long into the abyss, the abyss gazes long into you.
TheMightyMoe
Captain
Captain
 
Posts: 705
Joined: Sat Apr 18, 2009 9:56 pm

Re: Problem with ICS SR-16

Postby TheUgly » Thu Sep 15, 2011 10:21 pm

Hmmmm maybe ill switch out the nozzle and see what that does.

Thanks Moe.
User avatar
TheUgly
Master Sergeant
Master Sergeant
 
Posts: 303
Joined: Sun Apr 26, 2009 9:43 pm


Return to Technical Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron